Fluent Home Help Center

    What is the minimum operating system needed for the Arlo?

    March 20th, 2020

    • Any phone or tablet with iOS 10.3 or Android 4.1 or higher.
    • For the best experience, we recommend devices with operating systems that are actively supported by Arlo: iOS 11 (or higher) and Android 5.0 (or higher). tvOS is not currently supported.

    Did this help resolve your question?

    Send feedback

    Can’t find what you’re looking for?

    Our award-winning customer care team is here for you.

    Contact Support